Ghosts multiplayer bt infinity

gerryb

Member
Hi,

I am far less than a beast player but since starting playing ghosts on xb1 i seem to be permanently half a second behind the action. I lose maybe 90% of all one on one encounters, very often being 'zero shotted' i.e die with no shots fired at me on my screen but the killcam showing at least half a clip fired at me. My i ternet is fine and xb1 is wired. I tried w/l as well and its the same. Is this typical for a fast internet connection?

Thx
 

Dexy

Well-known Member
Not typical at all. What speeds are you running? I played with 3meg and seem to be ok enough to play decent. Also what is your nat type? Is it open or moderate?
 

dynamicpanda

Active Member
check your ping the lower the better
i have a 7meg connection with a 35ms ping your should be much lower
as for losing one on ones am in the same boat and i never got bad at COD over night
 

gerryb

Member
Not typical at all. What speeds are you running? I played with 3meg and seem to be ok enough to play decent. Also what is your nat type? Is it open or moderate?
I have open NAT on both xbox and ghosts. I get 76MB d/l and 17MB u/l. Ping is between 10 and 15 seconds typically from my PC. However I notice that if I use the XB1 "test connection" facility d/l is around 28MB and "latency" is 150ms. Everything else is fast as lightning, YT, bittorrent etc. Cannot figure it unless its some in-game lag/connection compensation which is penalizing fast connections.
 

Von Smittle

Well-known Member
I have 36meg bt infinity and it plays fine for me, not noticed any lag.
 

PA77ULY

Banned
Make sure port 3075 (UDP & TCP) are open on your router, this extra port is needed for COD.
Why is this needed mate? I've got Infinity and not opened any ports and though my NAT is Moderate (was the same on both my Home Hub 3 and now my new Home Hub 5), I can get into games no problem.

In saying that, though the game appears to play fine with no visible lag, the majority of the kill cams confirm lag is most certainly there.
 

messenger

Well-known Member
Why is this needed mate? I've got Infinity and not opened any ports and though my NAT is Moderate (was the same on both my Home Hub 3 and now my new Home Hub 5), I can get into games no problem.

In saying that, though the game appears to play fine with no visible lag, the majority of the kill cams confirm lag is most certainly there.
Yeah im on infinity 2 as well & it is pretty well documented across the net that with X1 its better to port forward all the ports individually on your router to ensure an 'open' nat. Anything less than an open NAT will account for the OP's problems & it appears with just COD only you also need to port forward 3075 (UDP & TCP) to maintain an open NAT.

I have an HH5 & with the 360 there were no problems with open NAT, but the X1 appears a little different at present, until MS provide a fix, so the only work around is to give your X1 a static IP address & port forward all the Xbox Live ports through your router.

Roll on IPv6 as this will eliminate NAT problems but how long this will take for UK ISP's to take up is anyone's guess...
 

PA77ULY

Banned
Yeah im on infinity 2 as well & it is pretty well documented across the net that with X1 its better to port forward all the ports individually on your router to ensure an 'open' nat. Anything less than an open NAT will account for the OP's problems & it appears with just COD only you also need to port forward 3075 (UDP & TCP) to maintain an open NAT.

I have an HH5 & with the 360 there were no problems with open NAT, but the X1 appears a little different at present, until MS provide a fix, so the only work around is to give your X1 a static IP address & port forward all the Xbox Live ports through your router.

Roll on IPv6 as this will eliminate NAT problems but how long this will take for UK ISP's to take up is anyone's guess...
Cheers for the response mate. I must admit I don't know a lot about opening ports but are you saying if you open the necessary ones then you should have an open NAT?

If so, given you also have the HH5, would it be possible to send you a conversation later so you can run me through the process of opening them ?!
 

messenger

Well-known Member
Cheers for the response mate. I must admit I don't know a lot about opening ports but are you saying if you open the necessary ones then you should have an open NAT?

If so, given you also have the HH5, would it be possible to send you a conversation later so you can run me through the process of opening them ?!
Err cant guarantee I'll be on here later mate, sorry...

But this should help you solve the open NAT problem, taken from BT care forums;

First of all open internet explorer in the xbox one and make sure you have already gone through smart settup and turned off parental controls.
Afterwards put the xbox in energy saving mode and switch it off.
Next open a web browser on your PC.


First go into the hub settings by typing bthomehub.home in the address bar. If that doesn't work then try typing 192.168.1.254.

Click advanced settings. Type in password if asked then click go to advanced settings.

Click 'Home Network'

Then find the xbox one in the network diagram. By default it should be listed as Xbox-SystemOS

Where it says always use this IP address click 'Yes' then click Apply.

Next Click the Firewall tab then click port forwarding.

Click 'Manage games and applications'

Click 'Add new game or application'

Where it says game or application name just type COD XB1
Where it says Copy an existing game or application click 'No'
Where it says protocol leave as 'Any'
In the port range setting type 3075 - 3075
leave translate to blank then click add
Click apply then OK.
Go back to main port forwarding screen then where it says Game or application click the arrow in the drop down box and select COD XB1. In the device box select XBox- SystemOS.


Then click add then click Apply.
Switch xbox back on and try testing multiplayer connection again after testing press and hold both triggers and bumper buttons at the same time. this should open the nat on dashboard.
Also try cod and you should now have an open NAT


If you still have a moderate NAT after the above scream.... No seriously you can still try going into the advance settings on the HH5 router, click 'Firewall' then on the port forwarding page select Xbox Live from the drop down menu "Game or Application" & assign that to Xbox-SystemOS in the 'Device' drop down menu. Then click the 'apply' button.

Again, Switch xbox back on and try testing multiplayer connection again, after testing press and hold both triggers and bumper buttons at the same time. this should open the nat on dashboard.

Good Luck :)
 

PA77ULY

Banned
Cheers mate, I really appreciate that very detailed response.

Shall give it a go once the little one has gone down.
 

PA77ULY

Banned
Cheers mate, I really appreciate that very detailed response.

Shall give it a go once the little one has gone down.
Update: That trick has......... Well done the trick! I now have an Open NAT on both the dashboard and COD.

Cheers for your help again messenger.
 

Boozehound

Banned
None of that works on the Homehub 3 (borked software which BT are ignoring - check their forums).
 

x Dr Vodka x

Active Member
This worked on my HH3 ! Thanks
 

The SMF

Banned
doing tweaks on your router is fine, until your ISP decides to do some work on your connection line/area etc... then no matter what you do, you'll find it wont work as your ISP is tweaking it in the 1st place

personally i dont believe in all this, you can fix it by tweaking your settings on the router, it all feels a bit myth like to me, you may be able to control certain elements but overall the powers that be at your ISP are really the ones in control, theres nothing you can change about that i know
 

messenger

Well-known Member
After the last patch I found my NAT type had dropped back to moderate, reconfigured router with all those Xbox live ports, including 3075 especially for ghosts, & still no joy. Read many forums & found for COD Ghosts V2 you now need to port forward 3076 (UPNP/TCP) as well to ensure an open nat.

Worked for me on a BT HH5.
 

The latest video from AVForums

Panasonic HZ2000 OLED TV Review: The best OLED for movie viewing in 2020
Top Bottom