Icecrypt T2200 Freeview HD Receiver

sheba789uk

Novice Member
Hi have had this Freeview box now for some time and everything was fine until I got a new tv which just has hmdi connectors on it, so plugged the hmdi cable and all I get is no signal on the tv and yes its on the correct channel. the tv aerial goes into the box and then into the tv this is working as the Freeview on the tv is working and when the aerial is taken out of the box it does not work. Any help here please as I am at a loss to get it working.
 

EndlessWaves

Distinguished Member
Do you actually need the box? Looking it up it appears to be redundant, everything it can do is built into new TVs.
 

JayCee

Distinguished Member
With the TV switched to whatever HDMI input the box is plugged in to are you able to bring up the Freeview box's menu?
 

JayCee

Distinguished Member
Does the box have a power/standby Led on the front and does it change from red to green (or whatever colour it's supposed to be) when switched on?
 

sheba789uk

Novice Member
Yes it turns on boots up and shows which channel you are on but still gives a blank screen with no signal showing.
 

JayCee

Distinguished Member
Was it connected via scart on your old TV and this is the first time you've used it with HDMI?
If so, reconnect it to your old TV temporarily and go into the box's menu and set the video output to HDMI instead of scart. You will lose the picture but that doesn't matter.
Disconnect it from the old TV then connect it to the new one and hopefully you'll now get a signal from it via HDMI.
 

The latest video from AVForums

Podcast: TCL C815 TV, Denon & Huawei wireless speaker reviews, New Sony 4K PJ's and more
Top Bottom