Marantz SR6004 Loud POP now wont work!

goujam

Well-known Member
Hi,

I brought a Marantz SR6004 off another member last week and have been using it since saturday. Tonight while watching TV there was a loud pop and now all I get is a flashing standby light. Does anyone know what this could be and more inportantly how to fix it??

thanks

James
 

scottthehat

Distinguished Member
Have a look at the capacitors and see if any have blown.
 

scottthehat

Distinguished Member
Take the top of and just look for any blown or swollen capacitor and any burn marks also check fuses.
 

goujam

Well-known Member
Take the top of and just look for any blown or swollen capacitor and any burn marks also check fuses.
Well Ive just done a reset and its now switched on. I have googled the symptoms and it led me to the POP of Death problem and it said there was a 3 button reset. I need to read more about it to find out what causes it
 

dante01

Distinguished Member
the POP of Death problem and it said there was a 3 button reset. I need to read more about it to find out what causes it
Wasn't this featured in the movie "Kill Bill" pt2? :confused:

Good luck :)

IMPORTANT UPDATE - PLEASE READ BELOW BEFORE BUYING

MARANTZ SR6004 AND SR5004 POP OF DEATH

IMPORTANT UPDATE: MARANTZ HAS ALLEGEDLY SAID THE THAT SURROUND, CLEAR, AND EXIT RESET AFTER A POD CAN VOID THE WARRANTY

Numerous 5004 and 6004 owners both in North America, Asia, Australia and Europe have reported complete and inexplicable failure of the units with exact same POP of DEATH. Most of the failed units do so within the first 30 days, but others have reported POPs of DEATH after nearly four months of use. There is a poll tracking the failures and timing here:
http://www.avsforum.com/avs-vb/showthread.php?t=1199061
http://www.avsforum.com/avs-vb/showthread.php?t=1179621

MARANTZ SR6004 AND SR5004 POP OF DEATH

ESTIMATED* FAILURE RATE: 43%
* Per this poll tracking failures as of 9/21/10

Numerous 5004 and 6004 owners both in North America, Asia, Australia and Europe have reported complete and inexplicable failure of the units with exact same POP of DEATH. Most of the failed units do so within the first 30 days, but others have reported POPs of DEATH after nearly four months of use. We believe the POD is related to a design deficiency of the unit to take slight surges from cable or sat boxes. This is unconfirmed and pure conjecture based upon reported failures of owners.

UPDATE AS OF 1/22/10: IF YOU EXPERIENCE THE POP OF DEATH, YOU CAN SOMETIMES RESET THE UNIT BY PRESSING SURR MODE, CLEAR AND EXIT SIMULTANEOUSLY. PLEASE ALSO CALL MARANTZ AT 201-762-6666 AND REPORT YOUR FAILURE
http://www.avsforum.com/avs-vb/showthread.php?t=1199061
 
Last edited:

dante01

Distinguished Member
Dante,

I have just been reading those threads, Ive asked the previouse owner if they had any problems and he says he didnt have any isses. Also reading those thread the fails seem to be in the first few months this unit must be a few years old now!
It could just be an issue caused by condensation shorting the speakers? The amps had a very sensitive surge protector that tripped far more frequently than actually required. You still need to do the reset to get it up and running again.

Is your house/room humid or does it suffer from condensation?
 
Last edited:

goujam

Well-known Member
It could just be an issue caused by condensation shorting the speakers? The amps had a very sensitive surge protector that tripped far more frequently than actually required. You still need to do the reset to get it up and running again.

Is your house/room humid or does it suffer from condensation?
No it doesnt suffer with condensation in the lounge, I was pressing the SPKR A/B button earlier to see what that does. Maybe that was the cause, but surely that should be an issue with it.

Its all up and running now it even remembered the setup so its back to how it was. Ive emailed Marantz to see if they have any advice ill have to see what happens now.

I was going to try th Bi-amp feature out the weekend I may just leave it!!
 

Similar threads

The latest video from AVForums

Podcast: Samsung HW-Q950T Soundbar Review, Filmmaker Mode, Disney+ $30 for Mulan, AV news and more
Top Bottom