Quantcast

Philips OLED+ 934 4K TV Hands On Review & Comments

Interesting stuff! I don’t have a TV antenna, (or TV licence) so not sure where this leaves me, but I’ll play around tomorrow and report back.

Thanks for the update.
 

eddablin

Member
For those looking for the smart TV apps working via Freeview play, I stumbled on something today and mine are now all working. Typically I use a BT youview box, so have never set the TV up for antenna input.

Because I was having some subwoofer output issues, iPlayer not loading and Amazon lip sync issues. I decided today to do a full TV reset via the menu.

To my surprise on a new OS built after the December update, the UK Freeview play TV apps appeared in my app selection (never been there before). They couldn't be opened due to an error, something I similarly have seen on another TV. So I plugged my Freeview antenna cable into the TV, did a full channel scan. Then found that I could launch the smart TV apps from the TV guide using the red button. Once registered and accepted onto each. I turned the TV off, took out the antenna cable and powered back on. To my surprise all of the Freeview play apps now still work . Give it a try.
Fantastic. This is now wife friendly. Now to buy.
 

eddablin

Member
I didn't get the red button working and wasn't content with going through Freeview app. Looks like people are having to do similar on other Philips TVs. Process to get full apps working and in homescreen as attached photo is to:

1. Fully update
2. Scan channels with antenna plugged in. Cheap portable one may work if you don't have coax feed.
3. Do a reinstall (not factory reset) from Philips setting menu. Scan for channels in process.
4. Can then remove coax if you wish.

Then voila. Apps all fully appear as photo. Worked for me at least.
 

Attachments

coachdriver

Active Member
Just followed your suggestion and is now working for me as well.

Bit of a pain to have to setup all the logins and passwords again but is worth it.

As an aside has anybody installed the dPlay catchup and can actuallly play any content. I can see the programmes but get a internet failure message when the content is about to stream. I have a WiFi connection for the TV but all other apps stream with no issues.
 

peyroutet

Novice Member
I'm almost 100% sure Philips 934 (65") will be my next TV but a few comments bother me regarding sound and crackle noises when using an external tv box

It is mentionned by @Domsy on a few posts (using shield) and on this FlatPanel review (using apple tv).

This is a main drawback and I'm wondering if everybody encounters this issue ?
Is this supposed to be fixed on a future firmware update ?

Thanks for your feedback.
 

coachdriver

Active Member
Use a Humax Freeview recorder, a Samsung Blu-ray and a 4K Apple TV and no issues with any crackles.

Sound is very good especially with a subwoofer attached.
 

Domsy

Standard Member
I'm almost 100% sure Philips 934 (65") will be my next TV but a few comments bother me regarding sound and crackle noises when using an external tv box

It is mentionned by @Domsy on a few posts (using shield) and on this FlatPanel review (using apple tv).

This is a main drawback and I'm wondering if everybody encounters this issue ?
Is this supposed to be fixed on a future firmware update ?

Thanks for your feedback.
I'm not getting crackling anymore, but I'm still getting frequent no sound with the Shield when first turning the TV on. It's happening about 3 times a week now and requires restarting by unplugging the TV. I never know if it's going to do it, so there's always some apprehension whenever I turn it on.

I've also noticed it frequently does a full boot instead of resuming when I turn it on lately, which takes a while, but at least the sound is always fine if it does.

Just got an update today (manually checked) so will let you know if there's any change. Anyone got a change log or any idea what's changed/fixed? It's version: TPM191E_R.001.002.173.008. Looks to be from Dec 23 so I'm a bit late updating despite having automatic updates on, unless they've just released it late as I swear I've checked for updates since then!
 

Supermal

Active Member
Just got this too but had to check for it. No notes in the logs on the product page on Philips website
Not really an update,more a notification of support added for freeview play.Looks like they have removed 007 from release notes and made it 008.
 

wofferx

Novice Member
Hi guys, I just purchased this beast. Everything is great but I can't update it. My TV is on 001.001.114.005 software. When I go to update I get a message that my TV is updated. When I go to Philips support page the last version there is 001.001.114.002. This for me means there is no Dobly Atmos on Netflix because you need 001.002.173.004 to have it... I waited a few days to see if a TV will offer me an update but nothing. Does anyone have any suggestions?
 

Supermal

Active Member
Hi guys, I just purchased this beast. Everything is great but I can't update it. My TV is on 001.001.114.005 software. When I go to update I get a message that my TV is updated. When I go to Philips support page the last version there is 001.001.114.002. This for me means there is no Dobly Atmos on Netflix because you need 001.002.173.004 to have it... I waited a few days to see if a TV will offer me an update but nothing. Does anyone have any suggestions?
All I can suggest is a full factory reinstall to see if it updates to latest software.Have you got an aerial connected as this seems to make a difference?
 

wofferx

Novice Member
Did it update when you first set it up?What does it say in update history?What region are you in?Are you connected to internet by wifi or wired?Sorry for questions just trying to help.
it did not update when I first set it up, it came with 001.001.114.005 and in update histroy it is also just 001.001.114.005. I am in Croatia - no update, then I did full factory reset and set region to Germany - still no update. TV is connected thru Wifi
 

Similar threads

Trending threads

Top Bottom