Question Pioneer SW-8MK2 power "clicks" on and off while the rest of the system is off.

bcr621

Novice Member
I have this sub connected to a Marantz NR1605 receiver. It's set to power on and off with the receiver. When the rest of the system is off, the sub makes a click noise and the LED flashes once. after about 20-30 seconds, it clicks again. It does this at regular intervals every few minutes. It sounds as if the sub is powering on and off by itself. I've disconnected it from the receiver and it continues to do this. It's actually been doing it for several months, I just never realized where the clicking noise was coming from. I have no idea what could be causing this. Does anyone have any ideas or suggestions? TIA
 

bcr621

Novice Member
I have this sub connected to a Marantz NR1605 receiver. It's set to power on and off with the receiver. When the rest of the system is off, the sub makes a click noise and the LED flashes once. after about 20-30 seconds, it clicks again. It does this at regular intervals every few minutes. It sounds as if the sub is powering on and off by itself. I've disconnected it from the receiver and it continues to do this. It's actually been doing it for several months, I just never realized where the clicking noise was coming from. I have no idea what could be causing this. Does anyone have any ideas or suggestions? TIA
Never mind, found the issue.
 

The latest video from AVForums

Panasonic HZ2000 OLED TV Review: The best OLED for movie viewing in 2020
Top Bottom