Question Starship Troopers

Itsthesmell

Active Member
I heard starship troopers is excellent in 4K and Dolby Atmos, so I bought it from eBay, new, and on the back it says Dolby Atmos logo but when I insert it into my bluray player it doesn't say Atmos or have a menu selection for it. Was it rereleased with Atmos?
 

GoingGoingGone

Distinguished Member
I heard starship troopers is excellent in 4K and Dolby Atmos, so I bought it from eBay, new, and on the back it says Dolby Atmos logo but when I insert it into my bluray player it doesn't say Atmos or have a menu selection for it. Was it rereleased with Atmos?
My original release (USA) has dolby atmos selection available in the disc menu. Are you sure you are playing the UHD and not the blu-ray?
 

shotokan101

Distinguished Member
4k player? 👿
 

shotokan101

Distinguished Member
No other Atmos discs to check with?
 

Nayfne

Distinguished Member
Have you set the player to Bitstream on the audio side?
 

shotokan101

Distinguished Member

Itsthesmell

Active Member
I've gone through the settings to force it to use Atmos and its playing true HD. They must have released it twice and I've bought the wrong one, again. I wish they'd stop doing that, ripping people off to get extra sales
 

Jim Di Griz

Distinguished Member
I've gone through the settings to force it to use Atmos and its playing true HD. They must have released it twice and I've bought the wrong one, again. I wish they'd stop doing that, ripping people off to get extra sales
Could be your amp telling you that even though it is Atmos? I highly doubt they'd re-release it with an inferior audio track.
 

shotokan101

Distinguished Member
Shouldn't it say on the rear of the case which sound formats are supported? :confused:
 

mckee74

Distinguished Member
No offence pal, but I am going to go with that you have something wrong on your set up rather than a second secret release without Atmos. Hope to be proven wrong though.
 

mikemag

Distinguished Member
Tried my copy, the disc defaults to Atmos as soon as you start to play it:

50E84915-9E2D-4EC5-919B-082D9499646F.jpeg


The player showed this information:

4AC3E2DD-36AE-49FF-A30D-169C8078F74F.jpeg
 

Itsthesmell

Active Member
So my amp is Dolby atmos but playing atmos shows a red logo TrueHD. If I click the display button it says Dolby atmos. Strange why they omitted a Dolby atmos light.
 

shotokan101

Distinguished Member
What's the amp?
 

shotokan101

Distinguished Member

shotokan101

Distinguished Member
I bought it because it was Dolby Atmos, that's all I know. Richer sounds sold it as that.
Upgrade the firmware to latest version and check again.....
 

Itsthesmell

Active Member
Looking at the amp, nowhere does it say Atmos on it so it must have came in with an update. Its on the latest firmware. So the disc is Atmos its just my amp. Nice one lads.
 

shotokan101

Distinguished Member
Personally I would have expected the update to display Atmos on the display....
 

The latest video from AVForums

Podcast: Marantz SR7015 & NAD T 778 AVR + Mission LX2 MKII Speaker Reviews, AV & Film News and More

Latest News

LG Display teams with Disney for OLED Projects
  • By Andy Bassett
  • Published
Campfire Audio updates Vega and Dorado earphones
  • By Andy Bassett
  • Published
Oppo launches S1 and R1 4K smart TVs
  • By Andy Bassett
  • Published
Lithe Audio AirPlay 2 ceiling speakers world's first
  • By Andy Bassett
  • Published
Humax launches AURA 4K Freeview Play Recorder
  • By Andy Bassett
  • Published
Top Bottom