V6 box Netflix and Prime issues

gforce08

Active Member
Hoping someone can help - recently got 2 v6 boxes and all is well most of the time. However when I try to use Netflix or Prime I almost always get blank screens when loading the content. Menus are fine, but as soon as I press play on something, generally I just get a blank screen or an error.

if I restart the box from the Virgin menu, and retry everything works ok. Then next time I use it a day or so later, the same thing happens. Really frustrating!

Have tried playing with video settings but nothing is helping. Have any of you had this issue and do you know of a fix?
 

dion 6

Active Member
Hoping someone can help - recently got 2 v6 boxes and all is well most of the time. However when I try to use Netflix or Prime I almost always get blank screens when loading the content. Menus are fine, but as soon as I press play on something, generally I just get a blank screen or an error.

if I restart the box from the Virgin menu, and retry everything works ok. Then next time I use it a day or so later, the same thing happens. Really frustrating!

Have tried playing with video settings but nothing is helping. Have any of you had this issue and do you know of a fix?
Hi I have had the same problem get to the homepage see all the shows and soon as I press play get a fault message or blank screen. I've had a new box the virgin tech guys have tried alsorts online but it was never fixed I give up in the end just to much hassle. I use the TV apps and a 4k firestick now much better than the virgin v6 box
 

gforce08

Active Member
Really frustrating- seems like there are complaints on the Virgin forums too. Not quite the one box solution I was hoping for! Still missing Disney+ too
 

dion 6

Active Member
Really frustrating- seems like there are complaints on the Virgin forums too. Not quite the one box solution I was hoping for! Still missing Disney+ too
Get a 4k firestick best cheap option great for amazon prime and Disney plus also does Netflix after weeks and weeks of contacting virgin its just to frustrating not worth the effort.
 

Bikerpaul

Standard Member
I have the same problem every couple of weeks. I have to restart the box, and then is all well until a few weeks later.
 

gforce08

Active Member
Thanks guys - I've been trying all sorts of things suggested on virgin forums but same behaviour. It works fine for maybe a day or 2 and then stops on both Netflix and prime. I have 2 boxes and 1 seems better than the other but it is also the one used less for netflix/prime so could just be that I don't notice it as often. A reboot works but given the reboot time is around 3-5 mins I find it irritating. Pity they can't resolve this as seems very common.
 

Stiff Dog TD

Active Member
We had the same issue of requiring a reboot every few switch on's, finally solved it by using the following settings.

Settings
Devices
Power saving
Always on.

Did this approx 4 months ago and never had an issue since, whether it will work with the apps i'm not sure but certainly sorted our problem out which we had had from day one.

Dave.
 

The latest video from AVForums

The Best Movies and TV Shows Coming to Netflix in November 2020: Tom's Thumbs.
Top Bottom